Log in

I forgot my password

Who is online?
In total there are 5 users online :: 0 Registered, 0 Hidden and 5 Guests

None

[ View the whole list ]


Most users ever online was 79 on 8/6/2015, 4:19 am



MG ZS bad day, wont start.

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

MG ZS bad day, wont start.

Post  Sambomonkee on 20/2/2012, 1:00 am

Ok, bad day today, final fixed the window, by a running a new wire the BCU, that was working, but now the car wont start, the fuel pump is not priming.

I have checked the fuses, press the fuel inertia button more than once, but nought, the pump doesn't fire. I unconnected to fuel hose to check if it was pressurised already, it wasn't none in it.

I checked the ECU, and it said fuel sensor low voltage, ie no fuel, yet I filled up the other day.

Now, is this a coincidence I was messing with the wires on the BCU, well only one the window down one, so have a fried the BCU or is there something else to check.

At this rate its going to the scrappers, argghhh.


avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  cejsmith on 20/2/2012, 3:18 am

I know that on the rover 75 the BCU does have some control over the fuel pump. if on the off chance it the same as the 75 on the zs i have a spare.




avatar
cejsmith
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 20/2/2012, 3:36 am

cheers colin but bcu are matted to car in mk2.

The BCU in the ZS only seems to control the key fobs, ie unlocking the car etc. I will ask Techonzen for advice as he knows them like the back of his hand


on further investigation, it no longer turns over now, but the fuel pump relay clicks when the ignition is turned on. I suspose it could be the fuel pump has died, but where is the damn thing in the ZS.



avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 20/2/2012, 4:17 am

Fuel pump in the tank, which means removing tank, arggh. I think I will see what technozen says.
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 20/2/2012, 5:21 am

Two things in mind are

1. SCU/ECU is buggered thanks to my wiring work, this is what I suspect is the issue
2. Fuel pump has died


First I have contacted these http://www.remobilise.co.uk/, and will get the SCU test first, before going down the fuel pump route.
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Matt Parker on 20/2/2012, 5:39 am

Well as you have been messing with the BCU then I would suggest that you have upset it as if it was working before you tried your window fix.

Have you checked all of the connections as in dis-connect and re-connect all of the plugs for the (S)BCU incase its jsut that it can't make a full connection.

The fuel pump wiring plug is on the drivers side rear corner of the tankl so you can dis-connect the pump multi plug and power that directly if you wanted to test the pump before dropping the tank, although dropping the fuel tank for the fuel pump on a ZR/ZS is fairly simple (more fun if you have alot of fuel in it Wink )


Matt

avatar
Matt Parker
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 20/2/2012, 5:44 am

Yes disconnected SCU and reconnected, disconnected battery, no difference. Pretty much tried everything.

Good tip on the fuel pump, I will give that a go, least I can independently test the fuel pump. But I believe the SCU is going off fore repair for the second time in my ownership. Perhaps I should leave the electrics well alone in the future.

avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 22/2/2012, 4:42 am

If anybody cares this is the dump from my SCU (i found it interesting), he still needs to do a full investigation to see if it is working correctly or not.

>> Raw Memory Dump...



4B BE 69 58 04 01 66 DC 7A B8 B6 1F 1E 1E 05 1E

07 02 04 01 05 7A 32 4C 91 31 10 03 0A 01 01 0A

00 00 72 A6 04 04 12 00 78 25 ED C7 83 60 01 00

00 05 AE 04 04 12 00 72 34 0D C8 83 60 01 FF FF

FF FF FF FF FF FF FF FF FF FF FF FF 4A FF FF FF

FF FF FF FF FF FF FF FF FF FF FF 4A FF FF FF FF

FF FF FF FF FF FF FF FF FF FF 4A FF FF FF FF FF

FF FF FF FF FF FF FF FF FF 4A FF FF FF FF FF FF

FF FF FF FF FF FF FF FF 4A FF FF FF FF FF FF FF

FF FF FF FF FF FF FF 4A FF FF FF FF FF FF FF FF

FF FF FF FF FF FF 4A FF FF FF FF FF FF FF FF FF

FF FF FF FF FF 4A FF C6 A5 0A 21 4E 08 42 00 A8

3A 53 90 9E 4E D0 03 80 01 10 31 52 54 63 85 98

04 06 10 FF FF FF FF FF FF FF FF FF FF C6 A5 0A

21 4E 08 42 00 A8 3A 53 90 00 49 90 03 80 01 10

50 52 54 63 85 98 04 05 14 FF FF FF FF FF FF FF

FF FF FF C6 A5 0A 21 4E 08 42 00 A8 3A 53 90 00

49 D0 03 80 01 10 31 52 54 63 85 98 04 05 15 FF

FF FF FF FF FF FF FF FF FF C6 A5 0A 21 4E 08 42

00 A8 3A 53 90 9E 4E D0 03 80 01 10 31 52 54 63

85 98 04 06 10 FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF 59 57 43 00 06 05 00 05 04 FF 53

41 52 52 54 4C 4C 4C 46 35 44 36 33 38 35 39 38

28 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF FF FF FF FF 04 01 01 BF

87 02 00 00 12 43 03 42 45 45 02 00 02 4F 05 B0



>> Decoded Data...



VIN = SARRTLLLF5D638598



Data for Remote 1:

00 00 72 A6 04 04 12 00 78 25 ED C7 83 60

Status of Remote 1:

Programmed and enabled



Data for Remote 2:

00 00 05 AE 04 04 12 00 72 34 0D C8 83 60

Status of Remote 2:

Programmed and enabled



Data for Remote 3:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 3:

Not Programmed



Data for Remote 4:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 4:

Not Programmed



Data for Remote 5:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 5:

Not Programmed



Data for Remote 6:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 6:

Not Programmed



Data for Remote 7:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 7:

Not Programmed



Data for Remote 8:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 8:

Not Programmed



Data for Remote 9:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 9:

Not Programmed



Data for Remote 10:

FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Status of Remote 10:

Not Programmed



EMS Code = 4B BE



EKA Digits = 69 58
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Nick on 22/2/2012, 6:27 am

You might want to remove your vin number and the EKA code from your post (yup I read it but have no idea what most if it means Wink


Last edited by Nick on 22/2/2012, 6:32 am; edited 1 time in total


avatar
Nick
Admin/Moderator
Admin/Moderator


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Rich on 22/2/2012, 6:29 am

You know, that's gotta be the most interesting post on our forum... If you haven't got a life! Laugh my a**e off!


Red Face ... Sent from my abacus using wooden beads

avatar
Rich
Admin/Moderator
Admin/Moderator


http://www.southmids-sportsters.org

Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 22/2/2012, 7:28 am

Right SCU is fine, so, anybody got any ideas, I still have to test the fuel pump. The only other thing I can think of is that when putting on the new exhaust I have damaged the wiring to the fuel pump so how.

avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Matt Parker on 22/2/2012, 7:44 am

Check and test the fuel pump wiring and then we can go from there.

What features do you have on the car, is it full electric windows, front fogs, climate control, heated seats etc, as usefull to know as with you posting the scu codes so another could be programmed to have full electric windows etc Wink


Matt

avatar
Matt Parker
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 23/2/2012, 12:41 am

Anybody got the rave wiring diagrams for Mk2 ZS, specifically the fuel system, in relation to the SCU. I only have Mk1 diagrams.

When cutting the window wire I cut wiring 12 , which is meant to be the down window wire, but I want to check it all against the diagrams (I may have connected my window to the fuel pump control wire Dunno!.
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Rich on 23/2/2012, 3:09 am

So if you want to drive anywhere, just keep opening and closing the window... Simples! Coffee


Red Face ... Sent from my abacus using wooden beads

avatar
Rich
Admin/Moderator
Admin/Moderator


http://www.southmids-sportsters.org

Back to top Go down

Re: MG ZS bad day, wont start.

Post  Matt Parker on 23/2/2012, 7:33 am

I have all the diagrams etc but it would be easier if you told me what wires you have cut of what plug and which wires/plugs have been altered from before the problem Smile


Matt

avatar
Matt Parker
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 24/2/2012, 5:53 am

Matt,

Got the SCU back today, and it now turns over but no fuel pump.

I have done this

the multi plug on the SCU next the orange one, I cut connection 12, and spliced a new wire in this worked and fixed the window. Just to be sure, I re-wiring it back to the original and still no start and no window.

I 99.99% sure its the correct wire it fits the wiring diagram and is the right colour.

2. I changed the fuel filter, turned over and nothing, disconnected the hose turned over again, and no fuel, so pump is just not running.

3. I can here the fuel pump relay click on for a few seconds and then turn off, as it would normally to prime the pump.

4. I disconnected the wiring loom at the back of the car, under the fuel tank and tested voltages there, got 12v and 6v, but without the wiring diagram I have no idea what pin does what, and I'm not going to try and connect the fuel pump to a battery without knowing which pin does what.

5. I know the fuel gauge sender works as when I reconnected the loom, the fuel gauge went back to its correct position.

I think its either the ECU, I think the ECU controls the pump?? (but I do hear the fuel pump relay click, so not sure), or the fuel pump has died.

I can get the ECU tested next week, but really need the wiring diagram for the fuel system to check the pump, if that works, its got to be wiring or ECU.

Thanks for reading Smile
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 25/2/2012, 2:02 am

Got hold of the rave c.

so I reckon its down to

1. Connection 3 on c0661 plug which connects the SCU, probably not a coincidence that the window wires are on this plug (12 and 13), I may have nicked or broken the wire internally, I will test the fuel pump relay, as that will define if the wire is broken or not, ie led or multimeter across the relay switching circuit. The 6v I got yesterday hints at this, IE broken wire)

2. Failed fuel pump
3. Bad earth in the rear of the car (fuel pump one)
4. Bad ECU

Thats pretty much all it can be in my book.

avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 25/2/2012, 5:38 am

I feel like I talking to myself, but its good to document what's been done somewhere.

So....

Its not ECU SCU, or my wiring, it looks like the fuel pump has died.

I disconnected the rear connection to the fuel pump shoved multimeter in the correct connections, and got someone to turn ignition on, 12v for a few seconds (what would normally be the priming time, double checked it at the relay end (engine) same result, check the continuity of the wire to the fuel pump (well the rear connection), all good.

So only thing it can be is the fuel pump (the sender still works so will assume the wiring to the pump is good), which is a pain since the car is full of petrol 50 litres, and the tank is damn heavy.

Also what is weird the wires fuel pump side are a different colour to what they are meant to be so looks like the pump has been changed before.

So off the ebay to get a second hand pump (Colin styley), so anybody any ideas how to drop the heavy fuel tank without crushing myself Smile

avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Tony on 25/2/2012, 6:25 am

Would it be possible to syphon some of the fuel out into your TF?


avatar
Tony
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 25/2/2012, 6:44 am

I thought that, but I think the car has a anti syphon, filler
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 26/2/2012, 12:52 am

Right, I think am going to do it like this.

1. drop the tank full, using a trolley jack or two and pieces of wood.
2. Rimmers are selling the ZS fuel tank for 48 pounds at the moment which is a bargain, and since the tank in there looks very rusty will be worth replacing.
3. Get a second hand pump from ebay 35 pounds.
4. Put the empty and very light tank back into the car with the replacement fuel pump.
5. Use a syphon pump to transfer the fuel from the old tank to the new one.

Jobs a goodun.
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Nick on 26/2/2012, 2:55 am

Now that sounds like a good plan. Pretty fortunate that the tank was on offer as well, good luck mate Smile


avatar
Nick
Admin/Moderator
Admin/Moderator


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sambomonkee on 28/2/2012, 5:14 am

Fuel tank, out, its rusted to a goodun, only spilt a tiny bit of fuel, but the hanger bolts sheered off. On rimmers website its number 29 on their diagram but they don't sell them. I could make my own but I would prefer the proper ones, anybody know where to get them?



and that is the good side!!!

EDIT: Ignore me, they are on there, just no under v6 section, but under 1.8, weird website!
avatar
Sambomonkee
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  darrenzs on 29/2/2012, 8:45 am

Is the new Tank painted?
avatar
darrenzs
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  c-j on 29/2/2012, 9:52 am

Lee,
Looks like you are getting there. Fingers crossed.

Feel free to shout if you need a hand,
Chris
Ps. I guess from your post that you have a syphon pump? If not I have a very cheap hand pump (100 yen!) bought just in case. Not sure how well it would work - last resort probably, but you are welcome to try if you need a backup etc.
avatar
c-j
Registered user
Registered user


Back to top Go down

Re: MG ZS bad day, wont start.

Post  Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum